Platform | Intermittent Errors on Web Application Platform
Incident Report for Procore Technologies
Resolved
During the incident, some users experienced intermittent errors on the Procore web application. Our engineering team has confirmed normal functionality has been restored, this incident has been resolved.
Posted May 17, 2024 - 08:54 PDT
Monitoring
Our engineering team has implemented a solution to remediate intermittent errors in the web application interface. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted May 16, 2024 - 14:27 PDT
Investigating
Our engineering team is investigating an issue where users may be experiencing intermittant errors on the Procore web application interface.

Additional updates will be provided as new information becomes available.
Posted May 16, 2024 - 14:27 PDT
This incident affected: Global Services (Web Interface).