Delay in Inbound Email Delivery
Incident Report for Procore Technologies
Resolved
During the incident, users experienced delays in Inbound Email delivery. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Mar 22, 2023 - 14:01 PDT
Monitoring
Our engineering team has implemented a solution to remediate delays in Inbound Email Delivery. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted Mar 22, 2023 - 13:09 PDT
Identified
Our engineering team has identified the cause of Inbound Email delays. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Mar 22, 2023 - 10:57 PDT
Investigating
Our engineering team is investigating an issue where users may be experiencing a delay in Inbound Email Delivery.

Additional updates will be provided as new information becomes available.
Posted Mar 22, 2023 - 10:53 PDT
This incident affected: Global Services (Emails - Inbound).