Regional Latency Issue

Incident Report for Procore Technologies

Resolved

This incident has been resolved, upload and download functionality is working as expected for all regions.
Posted Mar 24, 2026 - 10:21 PDT

Identified

Some users may experience intermittent data delays in certain regions. Upload and download performance may be slower than normal while we work to resolve a vendor issue. We will share updates as more information becomes available.
Posted Mar 24, 2026 - 09:27 PDT