Forms Tool Issue
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to the Forms tool and this issue is now resolved.
Posted May 03, 2021 - 11:19 PDT
Investigating
Our Engineering Team has identified the cause of an issue with the Forms tool and is working toward a resolution. Updates will be posted as they become available.
Posted May 03, 2021 - 10:26 PDT
This incident affected: Project Level Tools (Forms).