Issue Adding Distribution Members to Observations
Incident Report for Procore Technologies
Resolved
During the incident an issue caused Distribution Members to not be able to be added when creating Observations. Our engineering team has restored normal functionality and is confident there will be no recurrences. This incident has been resolved.

Impact Duration: 104 Minutes (4:31PM - 6:15PM PST)
Posted Jan 25, 2022 - 18:20 PST
Investigating
Our engineering team is investigating an issue causing an inability to add Distribution Members to Observations.

Additional Updates will be posted as they become available.
Posted Jan 25, 2022 - 16:39 PST
This incident affected: Project Level Tools (Observations).