Issues Accessing Company Level Timesheets Tool
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Jul 10, 2020 - 03:52 PDT
Update
Our Engineering Team is continuing to investigate the root cause of this issue and are working toward a full resolution. Updates will be posted as they become available.
Posted Jul 09, 2020 - 19:47 PDT
Investigating
Our Engineering Team is currently investigating issues with accessing the Company Level Timesheets tool. Updates will be posted as they become available.
Posted Jul 09, 2020 - 16:22 PDT
This incident affected: Resource Management Platform (Company Level Timesheets).