Scheduled Workflow Maintenance

Scheduled for Jul 31, 22:30 PDT  -  Aug 1, 02:30 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 16, 2026 - 11:09 PDT

Scheduled

Please be advised that scheduled maintenance will take place from Friday, 31 July 2026 at 10:30 PM to Saturday, 1 August 2026 at 2:30 AM Pacific (Saturday, 1 August 2026, 5:30 AM to 9:30 AM UTC). During this maintenance window, Workflows will be unavailable in supported tools.

This planned upgrade is part of our ongoing commitment to enhancing the reliability and performance of the Procore platform. We appreciate your patience and continued support as we work to serve you better.
Posted Jul 31, 2026 - 22:30 PDT
This scheduled maintenance affects: Company Level Tools (Workflows).