Problems downloading files via Google Chrome
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Apr 03, 2023 - 07:49 PDT
Update
This incident has been resolved. File download is functioning as expected.
Posted Apr 03, 2023 - 07:27 PDT
Update
Our engineering team is continuing to investigate an issue where users may be experiencing problems downloading files via Google Chrome and may be seeing warning messages on emails sent from Procore.

Additional updates will be provided as new information becomes available.
Posted Mar 31, 2023 - 08:05 PDT
Investigating
Our engineering team is investigating an issue where users may be experiencing problems downloading files via Google Chrome

Additional updates will be provided as new information becomes available.
Posted Mar 30, 2023 - 17:01 PDT
This incident affected: Global Services (File Downloads).