Intermittent Loading Failures for Multiple Tools

Incident Report for Procore Technologies

Resolved

This Incident has been Resolved.
Posted May 27, 2025 - 09:54 PDT

Monitoring

The vendor has implemented a fix and blank pages or loading failures on Procore tools are starting to recover. We will continue to monitor to ensure a full resolution.
Posted May 27, 2025 - 07:41 PDT

Identified

Engineers are aware of a vendor related issue causing impact where users may be experiencing blank pages and loading failures for multiple tools in Procore. RFIs, Submittals, and PDM have been impacted by this incident. Updates will be provided as they become available. Thank you for your patience.
Posted May 27, 2025 - 07:17 PDT
This incident affected: Project Level Tools (Document Management, RFIs, Submittals).