Delays in Inbound Email
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Nov 07, 2019 - 11:03 PST
Monitoring
Inbound email messages are now processing, and we are continuing to monitoring the situation.
Posted Nov 07, 2019 - 08:11 PST
Investigating
We are currently investigating delays seen in our inbound email processing. We will post updates as they are available.
Posted Nov 07, 2019 - 07:20 PST
This incident affected: Emails - Inbound.