Workforce Planning Performance Degradation
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Oct 24, 2022 - 13:46 PDT
Monitoring
Our third party vendor has implemented a solution to remediate performance issues with the Workforce Planning application. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted Oct 19, 2022 - 05:51 PDT
Identified
Our third party vendor has identified the underlying cause of the performance issues with the Workforce Planning application and is working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Oct 18, 2022 - 22:12 PDT
Update
We are continuing to investigate this issue.
Posted Oct 18, 2022 - 16:28 PDT
Investigating
Our engineering team is investigating an issue where users may be experiencing performance issues with the Workforce Planning application.

Additional updates will be provided as new information becomes available.
Posted Oct 18, 2022 - 16:27 PDT
This incident affected: Resource Management Platform (Workforce Planning Application).