Elevated Rate of Bounced Emails
Incident Report for Procore Technologies
Resolved
The bounce rate for emails sent by the Procore App have been returned to normal levels. This incident has been resolved
Posted Nov 15, 2021 - 07:29 PST
Investigating
Our engineering team is investigating an elevated level of bounced emails sent by the Procore app. We will post additional details as they become available.
Posted Nov 12, 2021 - 12:34 PST
This incident affected: Global Services (Emails - Outbound).