Users are unable to access Invoices at this time

Incident Report for Procore Technologies

Resolved

During the incident, users experienced the inability to access invoices. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Feb 16, 2024 - 09:10 PST

Monitoring

Our engineering team has implemented a solution to remediate the issue where users have been unable to access invoicing. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted Feb 16, 2024 - 08:55 PST

Investigating

Our engineering team is investigating an issue where users may be experiencing the inability to access invoices.

Additional updates will be provided as new information becomes available.
Posted Feb 16, 2024 - 08:41 PST
This incident affected: Project Level Tools (Invoicing).