app.procore.com Load Issues
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to the Procore Web Interface and this issue is now resolved.
Posted Jun 21, 2020 - 08:58 PDT
Monitoring
Our Engineering Team has restored normal functionality to the Procore Web Interface and is monitoring to ensure this issue continues to stabilize. Updates will be posted as they become available.
Posted Jun 21, 2020 - 01:46 PDT
Investigating
Our Engineering Team is currently investigating intermittent issues of loading and accessing Procore. Updates will be posted as they become available.
Posted Jun 20, 2020 - 23:22 PDT
This incident affected: Global Services (Web Interface).