Intermittent Errors Accessing the Procore Application

Incident Report for Procore Technologies

Resolved

This incident has been resolved, the Procore application is functioning as expected.
Posted May 05, 2025 - 05:18 PDT

Identified

We understand users may be experiencing intermittent errors when navigating or logging in to the Procore Application. At this time, teams are working diligently to resolve the issue. Updates will be provided as they become available or within the next 60 minutes.
Posted May 05, 2025 - 04:51 PDT
This incident affected: Global Services (Login).