Slow Load Times Across Procore
Incident Report for Procore Technologies
Resolved
We now consider this issue resolved.
Posted 2 months ago. Aug 05, 2019 - 13:32 PDT
Monitoring
Our engineers have identified and resolved the root cause, and load times are back to normal. We will continue to monitor the situation.
Posted 2 months ago. Aug 05, 2019 - 13:17 PDT
Investigating
We are aware of the slow load times being seen across Procore. Our Engineering team is actively investigating the cause of this. We will provide updates as they become available.
Posted 2 months ago. Aug 05, 2019 - 12:46 PDT
This incident affected: Web Interface.