Issue with Inbound Emails
Incident Report for Procore Technologies
Resolved
During the incident, users experienced duplicate Inbound emails. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Jan 09, 2024 - 13:04 PST
Monitoring
Our engineering team has implemented a solution to remediate Inbound email sending duplicate emails. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted Jan 09, 2024 - 09:58 PST
Identified
Our engineering team has identified the cause of Inbound emails sending duplicate emails. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Jan 09, 2024 - 08:29 PST
This incident affected: Global Services (Emails - Inbound).