Upstream Timeout Errors
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Dec 08, 2020 - 10:40 PST
Monitoring
Our Engineering team has mitigated the upstream timeout errors on app.procore.com and is monitoring to ensure this incident is resolved.
Posted Dec 08, 2020 - 09:08 PST
Investigating
Our engineering team is investigating an issue causing upstream timeout errors when accessing the Procore App. Further updates will be posted as they are available.
Posted Dec 08, 2020 - 08:40 PST
This incident affected: Global Services (Web Interface).