Following a 60-minute observation period with no reported anomalies, Procore is fully operational. This incident is now Resolved.
Posted Nov 18, 2025 - 10:41 PST
Update
Our Public Cloud Service Provider has reported service restoration. After internal testing and validation it has been confirmed that the Procore application is functioning as expected. Teams will remain engaged in monitoring for the next 60 minutes to ensure full restoration.
Updates or changes to the current situation will be reported as new information becomes available.
Posted Nov 18, 2025 - 09:29 PST
Update
We are continuing to monitor the resolution from our Public Cloud Service Provider. Users may still observe intermittent failures within the Procore web application as these efforts continue.
Updates or changes to the current situation will be reported as new information becomes available or within the next 60 minutes.
Posted Nov 18, 2025 - 09:18 PST
Update
Our Public Cloud Service Provider has updated that full service restoration is no longer confirmed. Procore internal testing initially validated the application working as expected, however some recent reports show that some customers may still be experiencing intermittent issues or errors when navigating the application. Teams remain engaged in the incident and working towards full resolution.
Updates or changes to the current situation will be reported as new information becomes available or within the next 30 minutes.
Posted Nov 18, 2025 - 08:37 PST
Monitoring
Our Public Cloud Service Provider has reported service restoration. After internal testing and validation it has been confirmed that the Procore application is functioning as expected. Teams will remain engaged in monitoring for the next 60 minutes to ensure full restoration.
Updates or changes to the current situation will be reported as new information becomes available.
Posted Nov 18, 2025 - 07:33 PST
Update
Our Public Cloud Service Provider has reported some service restoration. Procore is continuing to do internal test validation to ensure recovery. At this time, users may still be experiencing intermittent issues when navigating the Procore platform.
Workaround: Mobile and API Ecosystem are fully operational at this time.
Posted Nov 18, 2025 - 07:00 PST
Update
Our Public Cloud Service Provider reports that they have restored their dashboard services and continue working to remediate the broad application services impact. Users may still observe intermittent failures and higher error rates within the Procore web application as these efforts continue.
This degradation is isolated to the web (browser) interface.
Workaround: Mobile and API Ecosystem are fully operational at this time.
Posted Nov 18, 2025 - 06:40 PST
Update
Our Public Cloud Service Provider continues remediation efforts for their incident. Users may still observe intermittent failures and higher error rates within the Procore web application.
This degradation is isolated to the web (browser) interface.
Workaround: Access via API and the Mobile application remains functional.
Posted Nov 18, 2025 - 06:09 PST
Update
Remediation efforts are continuing with our Public Cloud Service Provider, and while some service recovery is evident, users should anticipate continued intermittent instability and higher error rates when accessing Procore.
The current degradation is limited to the web (browser) experience only, leading to intermittent page loading failures and blank navigation components.
Access to Procore via API and the Mobile application remains functional.
Posted Nov 18, 2025 - 05:17 PST
Update
The public cloud service provider is showing signs of recovery within their services, but users may continue to observe higher-than-normal error rates when navigating the Procore platform as remediation efforts continue.
Posted Nov 18, 2025 - 04:45 PST
Identified
We have identified the cause as related to an outage from a public cloud service provider. Our engineering team is actively working to mitigate the issue.
Posted Nov 18, 2025 - 04:10 PST
Investigating
We are currently investigating an issue causing intermittent errors for some users. We will provide another update as soon as more information is available.
Posted Nov 18, 2025 - 04:02 PST
This incident affected: Global Services (Web Interface).