Issues Downloading Drawings and Submittal Attachments With Markups

Incident Report for Procore Technologies

Resolved

The issues where some users were unable to download drawings and submittal attachments with markups has been resolved.
Posted Sep 15, 2022 - 16:36 PDT

Investigating

Our engineering team are investigating an issue where some users are unable to download drawings and submittal attachments with markups.
Posted Sep 15, 2022 - 15:28 PDT