Submittal Workflow Table
Incident Report for Procore Technologies
Resolved
Our engineers have restored normal visibility for the Submittal Workflow Edit table. This incident is resolved.
Posted 4 months ago. Jul 01, 2019 - 14:15 PDT
Identified
Our engineering team is aware of, and working on a solution for, issues viewing the Submittal Workflow's Edit table. We will post with updates to this as they are available.
Posted 4 months ago. Jul 01, 2019 - 13:31 PDT
This incident affected: Project Submittals.