Errors on File Uploads, and Delays in Background Jobs
Incident Report for Procore Technologies
Resolved
We have confirmed the errors are no longer occurring and have completed the backlog of jobs. All systems are now processing as expected. We consider this incident to be resolved.
Posted Jul 22, 2020 - 10:37 PDT
Monitoring
The 500 errors are no longer occurring and we are monitoring the situation to ensure a full resolution.

We are in the process of working through the backlog of background jobs, and a delay may still be experienced until this process has been completed.
Posted Jul 22, 2020 - 08:47 PDT
Investigating
Our R&D team is investigating the cause of 500 errors occurring on file uploads as well as delays being experienced in background jobs.
Posted Jul 22, 2020 - 07:56 PDT
This incident affected: Global Services (File Uploads).