Intermittent 500 Errors

Incident Report for Procore Technologies

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 05:09 PST

Monitoring

Errors are no longer happening across the application. We are monitoring to ensure a full resolution
Posted Mar 05, 2025 - 04:59 PST

Investigating

We are currently investigating intermittent errors across the web application and are working to resolve as quickly as possible.
Posted Mar 05, 2025 - 04:42 PST
This incident affected: Global Services (Web Interface).