Submittal Builder Not Finding Submittals
Incident Report for Procore Technologies
Resolved
We now consider this incident to be resolved, and are monitoring for any unexpected behavior.
Posted Feb 11, 2020 - 09:04 PST
Investigating
Our Engineering Team is currently investigating an issue with the Submittal Builder intermittently not being able to locate submittals. Updates will be posted as they become available.
Posted Feb 10, 2020 - 11:49 PST
This incident affected: Project Level Tools (Submittals).