Intermittent Errors in Documents Tool

Incident Report for Procore Technologies

Resolved

Our engineering team has implemented a solution to remediate intermittent errors affecting some customers when accessing the Documents tool. This incident is resolved.
Posted Sep 09, 2026 - 00:39 PDT

Identified

Our engineering team has identified the cause of intermittent errors affecting some customers when accessing the Documents tool. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Sep 09, 2026 - 00:30 PDT

Investigating

Our engineering team is investigating issues with accessing the Documents tool affecting some customers. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Sep 09, 2026 - 00:09 PDT
This incident affected: Company Level Tools (Documents) and Project Level Tools (Documents).