Email and Processing Delays

Incident Report for Procore Technologies

Resolved

During the incident, some users experienced delays with emails and processes on the web application. Our engineering team has restored normal functionality, this incident has been resolved.
Posted May 12, 2023 - 09:25 PDT

Investigating

Our engineering team is investigating an issue where some users may be experiencing delays with processes and email generation.

Additional updates will be provided as new information becomes available.
Posted May 12, 2023 - 08:27 PDT
This incident affected: Global Services (Emails - Outbound, Web Interface).