Outbound Email Delays
Incident Report for Procore Technologies
Resolved
During the incident, users experienced delays with outbound emails. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Dec 06, 2023 - 12:38 PST
Identified
Our engineering team has identified a situation causing delays with outbound emails. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Dec 06, 2023 - 11:30 PST
This incident affected: Global Services (Emails - Outbound).