Outbound Email Delays
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Jul 12, 2021 - 11:12 PDT
Monitoring
Our engineering team has implemented their solution and our outbound emails have resumed normal delivery times. We are monitoring the situation to ensure a complete resolution.
Posted Jul 12, 2021 - 10:31 PDT
Identified
Our engineering team has identified the cause of the outbound email delays and is working towards a solution. We will continue to post updates as they become available.
Posted Jul 12, 2021 - 06:28 PDT
Investigating
Our engineering team is investigating an issue causing delays in outbound emails. We will post updates as they are available.
Posted Jul 12, 2021 - 06:05 PDT
This incident affected: Global Services (Emails - Outbound).