Users are unable to close and distribute a submittal on the submittal form page
Incident Report for Procore Technologies
Resolved
During the incident, users experienced an issue where users were unable to close and distribute a submittal on the submittal form page. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Nov 02, 2022 - 14:26 PDT
Monitoring
Our engineering team has implemented a solution to remediate an issue where users were unable to close and distribute a submittal on the submittal form page. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted Nov 02, 2022 - 14:23 PDT
Investigating
Our engineering team is investigating an issue where users may be unable to close and distribute a submittal on the submittal form page.

Additional updates will be provided as new information becomes available.
Posted Nov 02, 2022 - 11:47 PDT
This incident affected: Project Level Tools (Submittals).