Text Issues Seen Across Procore
Incident Report for Procore Technologies
Resolved
Normal page loading has been restored. This incident has been resolved.
Posted 3 months ago. Jul 30, 2019 - 17:16 PDT
Monitoring
Assets were reloaded and we are monitoring the issue.
Posted 3 months ago. Jul 30, 2019 - 15:15 PDT
Investigating
Our engineers are investigating problems involving the appearance of some text across the Procore app. We will post updates as they become available.
Posted 3 months ago. Jul 30, 2019 - 12:31 PDT