Error when sending a password reset link

Incident Report for Procore Technologies

Resolved

During the incident, users experienced issue accessing the password reset link. Our engineering team has restored normal functionality, this incident has been resolved.
Posted May 23, 2023 - 18:54 PDT

Monitoring

Our engineering team has implemented a solution to remediate the password reset link issue. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted May 23, 2023 - 18:44 PDT

Investigating

Our engineering team is investigating an issue where users may be experiencing problems accessing the password reset link.

Additional updates will be provided as new information becomes available.
Posted May 23, 2023 - 18:12 PDT
This incident affected: Global Services (Emails - Outbound).