Degraded Site Performance
Incident Report for Procore Technologies
Resolved
Our engineering team has confirmed that errors are no longer occurring and background jobs are processing in the expected times. This incident has been resolved.
Posted Jul 28, 2022 - 13:10 PDT
Monitoring
Our engineering team has implemented their solution and is monitoring the situation closely to ensure a complete resolution. As part of this recovery, there will be a delay in background jobs as we work through a backlog that built during this incident. We will continue to post updates as they become available.
Posted Jul 28, 2022 - 12:11 PDT
Identified
Our engineering team has identified the cause of degraded performance across the Procore App and is working towards a solution. We will post additional updates as they become available.
Posted Jul 28, 2022 - 11:05 PDT
This incident affected: Global Services (Web Interface).