Blank pages seen when navigating to the budget page
Incident Report for Procore Technologies
Resolved
During the incident, users experienced blank pages when navigating to the budget page. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Mar 17, 2023 - 16:40 PDT
Identified
Our engineering team has identified the cause of users experiencing blank pages when navigating to the budget page. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Mar 17, 2023 - 13:27 PDT
Investigating
Our engineering team is investigating an issue where users may be experiencing blank pages when navigating to the budget page

Additional updates will be provided as new information becomes available.
Posted Mar 17, 2023 - 13:24 PDT
This incident affected: Project Level Tools (Budgeting).