Issue with Delayed Correspondence Emails
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to the Correspondence tool and this issue is now resolved.
Posted Mar 25, 2021 - 10:57 PDT
Identified
Our Engineering Team has identified the root cause of this issue and is working toward a resolution. Updates will be posted as they become available.
Posted Mar 25, 2021 - 10:33 PDT
Investigating
Our Engineering Team is currently investigating an issue causing a delay in email being sent from the Correspondence tool. Updates will be posted as they become available.
Posted Mar 25, 2021 - 09:53 PDT
This incident affected: Project Level Tools (Correspondence).