During the incident, users experienced delays with processing across multiple tools. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Jun 27, 2024 - 18:39 PDT
Monitoring
Our engineering team has implemented a solution to remediate delays with processing across multiple tools. We are monitoring the situation to ensure a complete resolution.
Additional updates will be provided as new information becomes available.
Posted Jun 27, 2024 - 17:28 PDT
Investigating
Our engineering team is investigating an issue where users may be experiencing delays with processing across multiple tools including Email delivery, Uploads in various tools, Image Processing, and Project Creation.
Additional updates will be provided as new information becomes available.
Posted Jun 27, 2024 - 13:25 PDT
This incident affected: Global Services (Emails - Outbound, File Uploads).