Intermittent Errors Accessing Pages
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Apr 20, 2021 - 10:37 PDT
Monitoring
Our engineering team has mitigated the issues causing the error pages and are monitoring the situation to ensure a complete resolution. We will continue to post updates as they become available.
Posted Apr 19, 2021 - 09:04 PDT
Investigating
Our engineering team is currently investigating an issue causing intermittent "upstream connection" error pages. Until this is resolved, refreshing the page will cause the page to load properly. We will post updates as they become available.
Posted Apr 19, 2021 - 08:18 PDT
This incident affected: Global Services (Web Interface).