During the incident, some users may have experienced intermittent 500 errors when navigating the Procore platform. Normal functionality has been restored and this incident is resolved.
Posted Sep 09, 2025 - 12:30 PDT
Monitoring
A fix has been implemented for the issue causing some users to intermittently experience 500 errors, and normal functionality has been restored to the Procore platform. We are monitoring to ensure a complete resolution.
Posted Sep 09, 2025 - 12:16 PDT
Identified
A fix is being implemented for the issue causing some users to intermittently experience 500 errors when navigating the Procore platform.
Posted Sep 09, 2025 - 12:05 PDT
Investigating
Some users may be experiencing intermittent 500 errors when navigating the Procore platform. We are working to restore normal functionality as quickly as possible.
Posted Sep 09, 2025 - 11:55 PDT
This incident affected: Global Services (Web Interface).