During the incident, users experienced new PDF attachments not loading and delays for certain processes across multiple tools. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Sep 15, 2023 - 20:00 PDT
Monitoring
Our engineering team has implemented a solution to remediate an issue where some users were experiencing new PDF attachments not loading and delays for certain processes across multiple tools. We are monitoring the situation to ensure a complete resolution.
Additional updates will be provided as new information becomes available.
Posted Sep 15, 2023 - 18:39 PDT
Investigating
Our engineering team is investigating an issue where some users may experience new PDF attachments not loading and delays for certain processes across multiple tools.
Additional updates will be provided as new information becomes available.
Posted Sep 15, 2023 - 14:25 PDT
This incident affected: Company Level Tools (Schedule) and Project Level Tools (Meetings, Punch List, Schedule, Submittals).