Issues Access Procore
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to the Procore Web Interface and this incident is now resolved.
Posted Jan 13, 2021 - 18:08 PST
Update
Our Engineering Team is continuing to investigate issues with accessing and loading Procore. Updates will be posted as they become available.
Posted Jan 13, 2021 - 16:52 PST
Investigating
Our Engineering Team is currently investigating issues with accessing and loading Procore. Updates will be posted as they become available.
Posted Jan 13, 2021 - 12:30 PST
This incident affected: Global Services (Login, Web Interface).