Regional Platform Degradation

Incident Report for Procore Technologies

Resolved

The vendor incident has been resolved and normal functionality has been restored to the Procore platform.
Posted Mar 05, 2025 - 15:53 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2025 - 12:35 PST

Identified

We are aware of an issue impacting customers within a specific region (Sydney, Australia) due to a vendor related incident. We are working with our vendor for up to date information as they work to find a resolution. During this time users may see intermittent errors when accessing the Procore platform.
Posted Mar 05, 2025 - 12:27 PST
This incident affected: Global Services (Web Interface).