Observations list view is empty
Incident Report for Procore Technologies
Resolved
We have resolved the issues within the Observations tool and user should now be able to see their Observations list view.
Posted 5 months ago. May 09, 2019 - 13:04 PDT
Investigating
We are investigating an issue where users of the Observations tool are unable to see the Observations list view. We will post updates here as they are available.
Posted 5 months ago. May 09, 2019 - 12:43 PDT
This incident affected: Project Observations.