Delayed Items Across Procore

Incident Report for Procore Technologies

Resolved

This incident has been resolved and PDF Generation, Outbound Emails, and Specification Uploads are processing as expected
Posted Jun 27, 2025 - 05:21 PDT

Monitoring

Engineers have implemented a fix for the delay in generating PDFS and Emails and are monitoring to ensure full resolution.
Posted Jun 26, 2025 - 12:30 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 26, 2025 - 10:43 PDT

Investigating

We are currently investigating a delay in generating PDFs and Emails across the Procore platform
Posted Jun 26, 2025 - 07:56 PDT
This incident affected: Global Services (Emails - Outbound, PDF Generation).