Procore Application Degradation

Incident Report for Procore Technologies

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 11:33 PST

Monitoring

A fix has been implemented, and users should no longer be experiencing intermittent errors on the Procore platform. We are currently monitoring the system to ensure stability and verify that the solution holds.
Posted Nov 24, 2025 - 09:43 PST

Update

Our team remains focused on resolving the intermittent errors some users are experiencing on the Procore platform. We appreciate your continued patience as we handle this issue with top priority.
Posted Nov 24, 2025 - 09:26 PST

Update

We are actively pursuing a solution for the intermittent errors some users are experiencing on the Procore platform. A temporary fix has been implemented to minimize impact while we move toward full resolution. We thank you for your patience as we address this issue with top priority.
Posted Nov 24, 2025 - 08:47 PST

Identified

Our engineering team is working toward a solution for the issue causing some users to intermittently experience errors when navigating and using the Procore platform. We thank you for your patience as we continue working on this issue with top priority.
Posted Nov 24, 2025 - 08:04 PST

Update

We are continuing to investigate an issue causing some users to intermittently experience errors when navigate the Procore platform. We thank you for your patience as we work on this with top priority.
Posted Nov 24, 2025 - 07:25 PST

Investigating

Our engineering team is investigating an issue causing some users to intermittently experience errors when navigating the Procore platform. We are working to resolve functionality as soon as possible.
Posted Nov 24, 2025 - 06:43 PST
This incident affected: Global Services (Emails - Outbound, Web Interface).