Slow Load Times and Error Pages
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Jan 14, 2021 - 10:54 PST
Monitoring
We have restored normal operations and are monitoring the situation to ensure a complete resolution.
Posted Jan 14, 2021 - 09:09 PST
Investigating
We are investigating issues causing slow load times and error pages in Procore. Further updates will be posted as they are available.
Posted Jan 14, 2021 - 08:50 PST
This incident affected: Global Services (Web Interface).