Inclement Weather Affecting Support
Incident Report for Procore Technologies
Resolved
The inclement weather affected our Support team members has passed and teams are now working at full capacity. Thank you for your patience with this matter.
Posted Feb 23, 2021 - 13:41 PST
Investigating
Due to the inclement weather affecting many of our Support team members, we are experiencing higher than normal wait times in responding to requests for support. We will be doing our best to reply to all requests we receive and appreciate your patience until we can return to normal staffing levels.
Posted Feb 16, 2021 - 07:56 PST
This incident affected: Supporting Platforms (Support Center).