Issues with Procore Owners Platform Support
Incident Report for Procore Technologies
Resolved
All issues affecting our Procore Owners Platform Support availability have been resolved. We apologize for the inconvenience.
Posted Jan 07, 2021 - 05:15 PST
Investigating
Our Support team for the Procore Owners Platform is currently unavailable. We are looking into the situation and will post updates as they become available.

If support is needed, please submit an email ticket to support-owners@procore.com and a support member will get back to you as soon as possible.
Posted Jan 06, 2021 - 12:08 PST
This incident affected: Procore Owners Platform (Bid Room, Capital Planning, Contract Room, Dashboard, Login, Project Page, Reporting) and Supporting Platforms (Support Center).