Outbound Email Delays
Incident Report for Procore Technologies
Resolved
Our engineering team has identified root cause of the outbound email delay and implemented a fix. No further delays should be observed. Thank you for your patience.
Posted 5 months ago. May 08, 2019 - 16:09 PDT
Investigating
We currently are investigating a delay in our outbound emails. We will provide an update as soon as one is available.
Posted 5 months ago. May 08, 2019 - 15:19 PDT
This incident affected: Emails - Outbound.